Electron-Vue,踩坑

  484 次阅读

CONTENT

之前一直研究的都是后端,四月份开始学习了下前端node.sj、vue等等。
以前也就熟知electron,但从未实操过,正好也是最近研究了下vue。
决定踩坑了!!!!

脚手架

Electron官方推荐了一个vue模板:https://github.com/SimulatedGREG/electron-vue
随后根据提供的文档开始使用:

初始化项目之后,发现依赖包版本都有些低
直接 yarn upgrade --latest。
升级之后 yarn dev ,试了一下果然各种大红。也没指望他可以直接运行

# 先升级babel,用官方提供的工具升级
npx babel-upgrade --write --install

这一套升级完基本上大问题都解决了。
BUT:

竟然把vue标签解释称 jsx.
二话没说直接百度、google,结果不尽人意。

紧接着检查.eslintrc.js,插件用着 'html'
果断安装 eslint-plugin-vue
跟着官方教程
https://eslint.vuejs.org/user-guide/#installation
操作之后木有问题了。
yarn dev 也正常了。所有包也都是最新的了(其实 不推荐使用最新的包)。

从没用过npm yarn 这些包管理工具,也没有太深究过前端的我
鼓捣这个东西,略有难度。
从初始化项目——更新包——运行demo
共耗时5个小时。其实不更新也是可以运行的~ 只是要试试

本文在后续还会持续更新

Comments | NOTHING

暂无评论...